#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+?(?:[- .]?\d{2})?[- .]?\d{4,5}[- .]?\d{3}[- .]?\d{3}$"
Local $sString = "+44 01726 400480" & @CRLF & _
"" & @CRLF & _
"+44 1726 400480" & @CRLF & _
"" & @CRLF & _
"+44 01726 400 480" & @CRLF & _
"" & @CRLF & _
"+44 1726 400 480" & @CRLF & _
"" & @CRLF & _
"01726 400480" & @CRLF & _
"" & @CRLF & _
"01726 400 480"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")