$re = '/^\+?(?:[- .]?\d{2})?[- .]?\d{4,5}[- .]?\d{3}[- .]?\d{3}$/m';
$str = '+44 01726 400480
+44 1726 400480
+44 01726 400 480
+44 1726 400 480
01726 400480
01726 400 480';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);