import re
regex = re.compile(r"^\+?(?:[- .]?\d{2})?[- .]?\d{4,5}[- .]?\d{3}[- .]?\d{3}$", flags=re.MULTILINE)
test_str = ("+44 01726 400480\n\n"
"+44 1726 400480\n\n"
"+44 01726 400 480\n\n"
"+44 1726 400 480\n\n"
"01726 400480\n\n"
"01726 400 480")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")