const regex = /^\+?(?:[- .]?\d{2})?[- .]?\d{4,5}[- .]?\d{3}[- .]?\d{3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+?(?:[- .]?\\d{2})?[- .]?\\d{4,5}[- .]?\\d{3}[- .]?\\d{3}$', 'gm')
const str = `+44 01726 400480
+44 1726 400480
+44 01726 400 480
+44 1726 400 480
01726 400480
01726 400 480`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}