import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+?(?:[- .]?\\d{2})?[- .]?\\d{4,5}[- .]?\\d{3}[- .]?\\d{3}$";
final String string = "+44 01726 400480\n\n"
+ "+44 1726 400480\n\n"
+ "+44 01726 400 480\n\n"
+ "+44 1726 400 480\n\n"
+ "01726 400480\n\n"
+ "01726 400 480";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}