#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(\w+)\s+\1\b"
Local $sString = "Paris in the the spring." & @CRLF & _
"" & @CRLF & _
"Not that that is related." & @CRLF & _
"" & @CRLF & _
"Why are you laughing? Are my my regular expressions THAT bad??"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")