using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\w+)\s+\1\b";
string input = @"Paris in the the spring.
Not that that is related.
Why are you laughing? Are my my regular expressions THAT bad??";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}