$re = '/\b(\w+)\s+\1\b/';
$str = 'Paris in the the spring.
Not that that is related.
Why are you laughing? Are my my regular expressions THAT bad??';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);