import re
regex = re.compile(r"\b(\w+)\s+\1\b")
test_str = ("Paris in the the spring.\n\n"
"Not that that is related.\n\n"
"Why are you laughing? Are my my regular expressions THAT bad??")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")