re = /\b(\w+)\s+\1\b/
str = 'Paris in the the spring.
Not that that is related.
Why are you laughing? Are my my regular expressions THAT bad??'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end