#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!00)\d{1,4}(?:\.\d{1,4}[aAxX]?)?$"
Local $sString = "Examples to pass:" & @CRLF & _
"0.2345X" & @CRLF & _
"1.23A" & @CRLF & _
"7300.3211x" & @CRLF & _
"0.1a" & @CRLF & _
"0.01" & @CRLF & _
"Examples to fail:" & @CRLF & _
"a.123" & @CRLF & _
"00.43x" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")