import re
regex = re.compile(r"^(?!00)\d{1,4}(?:\.\d{1,4}[aAxX]?)?$", flags=re.MULTILINE)
test_str = ("Examples to pass:\n"
"0.2345X\n"
"1.23A\n"
"7300.3211x\n"
"0.1a\n"
"0.01\n"
"Examples to fail:\n"
"a.123\n"
"00.43x\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")