const regex = /^(?!00)\d{1,4}(?:\.\d{1,4}[aAxX]?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!00)\\d{1,4}(?:\\.\\d{1,4}[aAxX]?)?$', 'gm')
const str = `Examples to pass:
0.2345X
1.23A
7300.3211x
0.1a
0.01
Examples to fail:
a.123
00.43x
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}