$re = '/^(?!00)\d{1,4}(?:\.\d{1,4}[aAxX]?)?$/m';
$str = 'Examples to pass:
0.2345X
1.23A
7300.3211x
0.1a
0.01
Examples to fail:
a.123
00.43x
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);