use strict;
my $str = 'Examples to pass:
0.2345X
1.23A
7300.3211x
0.1a
0.01
Examples to fail:
a.123
00.43x
';
my $regex = qr/^(?!00)\d{1,4}(?:\.\d{1,4}[aAxX]?)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}