import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.{1,50})(?:\\s|$)";
final String string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Integer pharetra metus risus, ac dignissim ante venenatis eget. Integer nulla metus, condimentum ac faucibus egestas, sagittis vitae ipsum. Donec fringilla scelerisque dui vitae aliquet. Aenean vel massa at neque ullamcorper luctus vel quis dui. Integer in libero imperdiet lectus pretium vulputate. Cras a congue erat. Cras non mattis velit. Cras hendrerit iaculis ante, vel rutrum odio feugiat id. Suspendisse maximus urna non elit bibendum luctus. Morbi mollis libero eget blandit rhoncus. Pellentesque mi turpis, bibendum ut elit eget, cursus mattis lorem.";
final String subst = "$1\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}