import Foundation
let pattern = #"(.{1,50})(?:\s|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Lorem ipsum dolor sit amet, consectetur adipiscing elit. Integer pharetra metus risus, ac dignissim ante venenatis eget. Integer nulla metus, condimentum ac faucibus egestas, sagittis vitae ipsum. Donec fringilla scelerisque dui vitae aliquet. Aenean vel massa at neque ullamcorper luctus vel quis dui. Integer in libero imperdiet lectus pretium vulputate. Cras a congue erat. Cras non mattis velit. Cras hendrerit iaculis ante, vel rutrum odio feugiat id. Suspendisse maximus urna non elit bibendum luctus. Morbi mollis libero eget blandit rhoncus. Pellentesque mi turpis, bibendum ut elit eget, cursus mattis lorem."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)