// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.{1,50})(?:\s|$)").unwrap();
let string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Integer pharetra metus risus, ac dignissim ante venenatis eget. Integer nulla metus, condimentum ac faucibus egestas, sagittis vitae ipsum. Donec fringilla scelerisque dui vitae aliquet. Aenean vel massa at neque ullamcorper luctus vel quis dui. Integer in libero imperdiet lectus pretium vulputate. Cras a congue erat. Cras non mattis velit. Cras hendrerit iaculis ante, vel rutrum odio feugiat id. Suspendisse maximus urna non elit bibendum luctus. Morbi mollis libero eget blandit rhoncus. Pellentesque mi turpis, bibendum ut elit eget, cursus mattis lorem.";
let substitution = "$1\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}