const regex = /(.{1,50})(?:\s|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.{1,50})(?:\\s|$)', 'gm')
const str = `Lorem ipsum dolor sit amet, consectetur adipiscing elit. Integer pharetra metus risus, ac dignissim ante venenatis eget. Integer nulla metus, condimentum ac faucibus egestas, sagittis vitae ipsum. Donec fringilla scelerisque dui vitae aliquet. Aenean vel massa at neque ullamcorper luctus vel quis dui. Integer in libero imperdiet lectus pretium vulputate. Cras a congue erat. Cras non mattis velit. Cras hendrerit iaculis ante, vel rutrum odio feugiat id. Suspendisse maximus urna non elit bibendum luctus. Morbi mollis libero eget blandit rhoncus. Pellentesque mi turpis, bibendum ut elit eget, cursus mattis lorem.`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);