# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.{1,50})(?:\s|$)"
test_str = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Integer pharetra metus risus, ac dignissim ante venenatis eget. Integer nulla metus, condimentum ac faucibus egestas, sagittis vitae ipsum. Donec fringilla scelerisque dui vitae aliquet. Aenean vel massa at neque ullamcorper luctus vel quis dui. Integer in libero imperdiet lectus pretium vulputate. Cras a congue erat. Cras non mattis velit. Cras hendrerit iaculis ante, vel rutrum odio feugiat id. Suspendisse maximus urna non elit bibendum luctus. Morbi mollis libero eget blandit rhoncus. Pellentesque mi turpis, bibendum ut elit eget, cursus mattis lorem."
subst = "$1\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.