package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`kod:[ ]([a-zA-Z]*)[ ]`)
var str = `sf sdf sdf kod: ahoj sdfsdfsf
kod:
kod: ahoj aaa
kod: ahoj
ahoj kod:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}