re = /kod:[ ]([a-zA-Z]*)[ ]/
str = 'sf sdf sdf kod: ahoj sdfsdfsf
kod:
kod: ahoj aaa
kod: ahoj
ahoj kod:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end