$re = '/kod:[ ]([a-zA-Z]*)[ ]/';
$str = 'sf sdf sdf kod: ahoj sdfsdfsf
kod:
kod: ahoj aaa
kod: ahoj
ahoj kod:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);