import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "kod:[ ]([a-zA-Z]*)[ ]";
final String string = "sf sdf sdf kod: ahoj sdfsdfsf\n"
+ "kod: \n"
+ "kod: ahoj aaa\n"
+ "kod: ahoj\n\n"
+ "ahoj kod:";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}