const regex = /(0[1-9]|[12]\d|3[0-1])[\./]([0[1-9]|1[0-2])[\./](196[1-9]|19[7-9]\d|20\d\d|2100)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(0[1-9]|[12]\\d|3[0-1])[\\.\/]([0[1-9]|1[0-2])[\\.\/](196[1-9]|19[7-9]\\d|20\\d\\d|2100)', 'gm')
const str = `01.12.1990
04.05.2000
31.12.2010
31.12.1980
31.12.1989
31.12.1999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}