import re
regex = re.compile(r"(0[1-9]|[12]\d|3[0-1])[\./]([0[1-9]|1[0-2])[\./](196[1-9]|19[7-9]\d|20\d\d|2100)", flags=re.MULTILINE)
test_str = ("01.12.1990\n"
"04.05.2000\n"
"31.12.2010\n"
"31.12.1980\n"
"31.12.1989\n"
"31.12.1999")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")