#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+[/]\d+[/]\d+[-\s\.]*\d+[/]\d+[/]\d+)"
Local $sString = "string1 = '11/13/2019 - 11/13/2019' " & @CRLF & _
"string2 = '11/14/2019 11/14/2019'" & @CRLF & _
"string3 = '01/21/2019. . 11/20/2019'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")