import re
regex = re.compile(r"(\d+[/]\d+[/]\d+[-\s\.]*\d+[/]\d+[/]\d+)", flags=re.MULTILINE)
test_str = ("string1 = '11/13/2019 - 11/13/2019' \n"
"string2 = '11/14/2019 11/14/2019'\n"
"string3 = '01/21/2019. . 11/20/2019'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")