# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.+ (?=\[\d+\]\.txt$)//gmi;t' <<< "ABC [1].txt
ABC [2].txt
ABC [10].txt"