$re = '/^.+ (?=\[\d+\]\.txt$)/mi';
$str = 'ABC [1].txt
ABC [2].txt
ABC [10].txt';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;