#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^.+ (?=\[\d+\]\.txt$)"
Local $sString = "ABC [1].txt" & @CRLF & _
"ABC [2].txt" & @CRLF & _
"ABC [10].txt"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)