#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""[\s\w]*"|("[^"]*")"
Local $sString = "" & @CRLF & _
""sele%ct"" & @CRLF & _
""select","Wow"" & @CRLF & _
""select" "wow" "w&ow"" & @CRLF & _
"" & @CRLF & _
"this has "some text within quotes"" & @CRLF & _
"" & @CRLF & _
"This has "one quote" & "another quote"" & @CRLF & _
"" & @CRLF & _
"This has "this & that" in quotes" & @CRLF & _
"" & @CRLF & _
"This has "this & that" as well as "something & another thing""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")