package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"[\s\w]*"|("[^"]*")`)
var str = `
"sele%ct"
"select","Wow"
"select" "wow" "w&ow"
this has "some text within quotes"
This has "one quote" & "another quote"
This has "this & that" in quotes
This has "this & that" as well as "something & another thing"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}