// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""[\s\w]*"|("[^"]*")"#).unwrap();
let string = "
\"sele%ct\"
\"select\",\"Wow\"
\"select\" \"wow\" \"w&ow\"
this has \"some text within quotes\"
This has \"one quote\" & \"another quote\"
This has \"this & that\" in quotes
This has \"this & that\" as well as \"something & another thing\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}