import Foundation
let pattern = #""[\s\w]*"|("[^"]*")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"sele%ct"
"select","Wow"
"select" "wow" "w&ow"
this has "some text within quotes"
This has "one quote" & "another quote"
This has "this & that" in quotes
This has "this & that" as well as "something & another thing"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)