re = /"[\s\w]*"|("[^"]*")/
str = '
"sele%ct"
"select","Wow"
"select" "wow" "w&ow"
this has "some text within quotes"
This has "one quote" & "another quote"
This has "this & that" in quotes
This has "this & that" as well as "something & another thing"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end