import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\b[a-z]{2}\\d\\b(?:(?:.(?!\\b[a-z]{2}\\d\\b))+\\s?)?";
final String string = "AE1 A D BE1 A D C\n"
+ "AE1 abc 123 EB2 a12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}