import re
regex = re.compile(r"(?i)\b[a-z]{2}\d\b(?:(?:.(?!\b[a-z]{2}\d\b))+\s?)?", flags=re.MULTILINE)
test_str = ("AE1 A D BE1 A D C\n"
"AE1 abc 123 EB2 a12")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")