re = /(?i)\b[a-z]{2}\d\b(?:(?:.(?!\b[a-z]{2}\d\b))+\s?)?/m
str = 'AE1 A D BE1 A D C
AE1 abc 123 EB2 a12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end