$re = '/(?i)\b[a-z]{2}\d\b(?:(?:.(?!\b[a-z]{2}\d\b))+\s?)?/m';
$str = 'AE1 A D BE1 A D C
AE1 abc 123 EB2 a12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);