const regex = /(?i)\b[a-z]{2}\d\b(?:(?:.(?!\b[a-z]{2}\d\b))+\s?)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)\\b[a-z]{2}\\d\\b(?:(?:.(?!\\b[a-z]{2}\\d\\b))+\\s?)?', 'gm')
const str = `AE1 A D BE1 A D C
AE1 abc 123 EB2 a12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}