#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d\.){4}\d"
Local $sString = "Нужно получить маску для инпута во vue по типу 1.1.1.1.1 без использования сторонних библиотек" & @CRLF & _
"Должно быть выражение разделенное точками, между которыми цифры. Минимум 5, но может быть и больше."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")