re = /(\d\.){4}\d/m
str = 'Нужно получить маску для инпута во vue по типу 1.1.1.1.1 без использования сторонних библиотек
Должно быть выражение разделенное точками, между которыми цифры. Минимум 5, но может быть и больше.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end