// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d\.){4}\d").unwrap();
let string = "Нужно получить маску для инпута во vue по тип у 1.1.1.1.1 без использования сторонних библиотек
Должно быть выражение разделенное точками, между которыми цифры. Минимум 5, но может быть и больше.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}