const regex = /(\d\.){4}\d/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d\\.){4}\\d', 'gm')
const str = `Нужно получить маску для инпута во vue по типу 1.1.1.1.1 без использования сторонних библиотек
Должно быть выражение разделенное точками, между которыми цифры. Минимум 5, но может быть и больше.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}