$re = '/(\d\.){4}\d/m';
$str = 'Нужно получить маску для инпута во vue по типу 1.1.1.1.1 без использования сторонних библиотек
Должно быть выражение разделенное точками, между которыми цифры. Минимум 5, но может быть и больше.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);