const regex = /(\d{1,2})\s*-\s*(\d{1,2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,2})\\s*-\\s*(\\d{1,2})', 'gm')
const str = `PERU
Liga 2
]
Final
Santa Rosa
0
-
3
Molinos El Pirata
73
Chavelines
1
-
0
Deportivo Coopsol
20:30
Comerciantes Unidos
-
Juan Aurich
22:45
Santos FC
-
Huaral
90+1
Pogon Szczecin
2
-
0
Stal Mielec
live
20:30
Plock
-
Gornik Z.
21:15
Farense
-
Maritimo
`;
const subst = `$1-$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);