import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.* )(?!.*[-,/.]{2})(?!.*(?:[^\\d\\n]*\\d){6})(?!.*([a-zA-Z])\\1\\1).{3,50}$";
final String string = "Time Square, Main Road, 2279\n"
+ "Time-Square, Main Road-2279\n"
+ "Time Square Main Road\n"
+ "Time Square, Main Road, 22798741313\n"
+ "Time Square, Main Road..\n"
+ "Time Square, Main Road//\n"
+ "Time Square Main Road,,\n"
+ "Time Square Main Road--\n"
+ "-------\n"
+ "--//\n"
+ "--/\n"
+ "ttttttttttttttttttttttttttt\n"
+ "/-/-/-/-\n"
+ "-/-\n"
+ "-/-\n"
+ ".,.\n"
+ ",-,\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}