import Foundation
let pattern = #"^(?!.* )(?!.*[-,/.]{2})(?!.*(?:[^\d\n]*\d){6})(?!.*([a-zA-Z])\1\1).{3,50}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Time Square, Main Road, 2279
Time-Square, Main Road-2279
Time Square Main Road
Time Square, Main Road, 22798741313
Time Square, Main Road..
Time Square, Main Road//
Time Square Main Road,,
Time Square Main Road--
-------
--//
--/
ttttttttttttttttttttttttttt
/-/-/-/-
-/-
-/-
.,.
,-,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)