re = /^(?!.* )(?!.*[-,\/.]{2})(?!.*(?:[^\d\n]*\d){6})(?!.*([a-zA-Z])\1\1).{3,50}$/m
str = 'Time Square, Main Road, 2279
Time-Square, Main Road-2279
Time Square Main Road
Time Square, Main Road, 22798741313
Time Square, Main Road..
Time Square, Main Road//
Time Square Main Road,,
Time Square Main Road--
-------
--//
--/
ttttttttttttttttttttttttttt
/-/-/-/-
-/-
-/-
.,.
,-,
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end